<!DOCTYPE html><html lang=en-US xmlns:og=http://opengraphprotocol.org/schema/ xmlns:fb=http://www.facebook.com/2008/fbml prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#"><head><style>img.lazy{min-height:1px}</style><link rel=preload href=https://www.phinsnews.com/wp-content/plugins/w3-total-cache/pub/js/lazyload.min.js as=script><meta charset="UTF-8"><meta name="viewport" content="width=device-width"><meta name="description" content="Phins News"><meta name="keywords" content="Phins News"><meta name="theme-color" content="#00838d"><meta name="apple-mobile-web-app-status-bar-style" content="#00838d"><meta name="msapplication-navbutton-color" content="#00838d"><title>Miami Dolphins 'run D' gets a big test v.s. the New England Patriots.</title><link rel=profile href=http://gmpg.org/xfn/11><link rel=pingback href=https://www.phinsnews.com/xmlrpc.php><link href="https://fonts.googleapis.com/css2?family=Montserrat:ital,wght@0,100;0,200;0,300;0,400;0,500;0,600;0,700;0,800;0,900;1,100;1,200;1,300;1,400;1,500;1,600;1,700;1,800;1,900&display=swap" rel=stylesheet> <!--[if lt IE 9]> <script src=https://www.phinsnews.com/wp-content/themes/phins/js/html5.js></script> <![endif]--><meta name='robots' content='max-image-preview:large'><link rel=canonical href=http://www.phinsnews.com/miami-dolphins-news-will-pats-tell-the-tale-on-phins-roster/ ><link rel=alternate href=https://www.phinsnews.com/en-us hreflang=en-us><meta name="description" content="The 2021 Miami Dolphins run defense will get tested early and often against the heavy rushing attack of the  New England Patriots in their home opener."><meta property="og:type" content="article"><meta property="article:published_time" content="2021-09-11"><meta property="article:modified_time" content="2021-09-11"><meta property="article:author" content="https://www.phinsnews.com/miami-dolphins-news-author/swriter3/"><meta property="article:section" content="Miami Dolphins News"><meta property="article:tag" content="Miami Dolphins 2021 Season"><meta property="article:tag" content="slider"><meta property="og:title" content="Miami Dolphins &#039;run D&#039; gets a big test v.s. the New England Patriots."><meta property="og:description" content="The 2021 Miami Dolphins run defense will get tested early and often against the heavy rushing attack of the  New England Patriots in their home opener."><meta property="og:url" content="https://www.phinsnews.com/miami-dolphins-news-will-pats-tell-the-tale-on-phins-roster/"><meta property="og:image" content="https://www.phinsnews.com/wp-content/uploads/2021/09/pats-vs-Dolphins.jpg"><meta property="og:site_name" content="Phins News"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="Miami Dolphins &#039;run D&#039; gets a big test v.s. the New England Patriots."><meta name="twitter:description" content="The 2021 Miami Dolphins run defense will get tested early and often against the heavy rushing attack of the  New England Patriots in their home opener."><meta name="google-site-verification" content="9nKubAwUaU4mUqCgJt4Ja7BdkUYNt7t114Zu34vnCLE"><link rel=dns-prefetch href=//www.googletagmanager.com><link rel=dns-prefetch href=//ajax.googleapis.com><link rel=dns-prefetch href=//s.w.org><link rel=alternate type=application/rss+xml title="Phins News &raquo; Feed" href=https://www.phinsnews.com/feed/ ><link rel=alternate type=application/rss+xml title="Phins News &raquo; Comments Feed" href=https://www.phinsnews.com/comments/feed/ ><link rel=alternate type=application/rss+xml title="Phins News &raquo; Will Pats &#8216;Tell the Tale&#8217; on Phins Roster? Comments Feed" href=https://www.phinsnews.com/miami-dolphins-news-will-pats-tell-the-tale-on-phins-roster/feed/ > <script>window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.phinsnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.1"}};!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style>img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel=stylesheet id=wp-block-library-css  href='https://www.phinsnews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.1' type=text/css media=all><link rel=stylesheet id=crp-style-rounded-thumbs-css  href='https://www.phinsnews.com/wp-content/plugins/contextual-related-posts/css/rounded-thumbs.min.css?ver=1.0.1' type=text/css media=all><style id=crp-style-rounded-thumbs-inline-css>.crp_related
a{width:150px;height:150px;text-decoration:none}.crp_related
img{max-width:150px;margin:auto}.crp_related
.crp_title{width:100%}</style><link rel=stylesheet id=st_css-css  href='https://www.phinsnews.com/wp-content/plugins/seoupro/modules/semtags/css/semantic_tags.css?ver=5.8.1' type=text/css media=all><link rel=stylesheet id=jquery-ui-style-css  href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/ui-darkness/jquery-ui.css?ver=1.11.4' type=text/css media=all><link rel=stylesheet id=yith-infs-style-css  href='https://www.phinsnews.com/wp-content/plugins/yith-infinite-scrolling/assets/css/frontend.css?ver=1.5.2' type=text/css media=all><link rel=stylesheet id=style.css-css  href='https://www.phinsnews.com/wp-content/themes/phins/style.css?ver=5.8.1' type=text/css media=all> <script src='https://www.phinsnews.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id=jquery-core-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id=jquery-migrate-js></script> <script src='https://www.phinsnews.com/wp-content/plugins/seoupro/modules/schema/assets/js/knockout-min.js?ver=5.8.1' id=knockout-js></script> <link rel=https://api.w.org/ href=https://www.phinsnews.com/wp-json/ ><link rel=alternate type=application/json href=https://www.phinsnews.com/wp-json/wp/v2/posts/40368><link rel=EditURI type=application/rsd+xml title=RSD href=https://www.phinsnews.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=https://www.phinsnews.com/wp-includes/wlwmanifest.xml><meta name="generator" content="WordPress 5.8.1"><link rel=shortlink href='https://www.phinsnews.com/?p=40368'><link rel=alternate type=application/json+oembed href="https://www.phinsnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.phinsnews.com%2Fmiami-dolphins-news-will-pats-tell-the-tale-on-phins-roster%2F"><link rel=alternate type=text/xml+oembed href="https://www.phinsnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.phinsnews.com%2Fmiami-dolphins-news-will-pats-tell-the-tale-on-phins-roster%2F&#038;format=xml"><style>0</style><meta property="fb:app_id" content="1540991332841094"><meta property="fb:admins" content=""><meta property="og:locale" content="en_US"><meta property="og:locale:alternate" content="en_US"><link rel=amphtml href=https://www.phinsnews.com/miami-dolphins-news-will-pats-tell-the-tale-on-phins-roster/amp/ ><link rel=icon href=https://www.phinsnews.com/wp-content/uploads/2020/09/logo.png sizes=32x32><link rel=icon href=https://www.phinsnews.com/wp-content/uploads/2020/09/logo.png sizes=192x192><link rel=apple-touch-icon href=https://www.phinsnews.com/wp-content/uploads/2020/09/logo.png><meta name="msapplication-TileImage" content="https://www.phinsnews.com/wp-content/uploads/2020/09/logo.png">  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-48791348-1"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','UA-48791348-1');</script> <meta name="google-site-verification" content="9nKubAwUaU4mUqCgJt4Ja7BdkUYNt7t114Zu34vnCLE"></head><body class="post-template-default single single-post postid-40368 single-format-standard wp-custom-logo"><div id=phins class=container><div class="head row py-3"><div class="col-md-6 logo"><div class="d-flex align-items-center"> <a href=https://www.phinsnews.com/ class=custom-logo-link rel=home><img width=128 height=131 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20128%20131'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/09/logo.png class="custom-logo lazy" alt="Phins News"></a>		<a class="site-title ml-2" href=https://www.phinsnews.com/ ><h1>Miami Dolphins News written for and by Phins fans!</h1> </a></div></div><div class="col-md-6 d-flex align-items-center desktop"><div class=ads> <a href="https://www.aceperhead.com/signup.php?CMPID=UGhpbnM%3D" target=_blank rel=nofollow> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/09/ace-banner-w728xh90.gif class="w-100 lazy" alt="aceperhead 6 weeks free"> </a></div></div></div><nav class="navbar navbar-expand-lg navbar-dark bg-dark border-nav"> <button class=navbar-toggler type=button data-toggle=collapse data-target=#mainNav aria-controls=mainNav aria-expanded=false aria-label="Toggle navigation"> <span class=navbar-toggler-icon></span> </button><div class="collapse navbar-collapse text-uppercase" id=mainNav><ul id=menu-menu-1 class="navbar-nav mr-auto"><li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-9317 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9317 nav-item"><a title=Home href=https://www.phinsnews.com/ class=nav-link>Home</a></li> <li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-3523 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-3523 nav-item"><a title=MultiMedia href=# data-toggle=dropdown aria-haspopup=true aria-expanded=false class="dropdown-toggle nav-link" id=menu-item-dropdown-3523>MultiMedia</a><ul class=dropdown-menu aria-labelledby=menu-item-dropdown-3523 role=menu> <li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-3525 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3525 nav-item"><a title="Classic Pics" href=https://www.phinsnews.com/miami-dolphins-news-classic-pics/ class=dropdown-item>Classic Pics</a></li> <li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-3524 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3524 nav-item"><a title="Original Artwork" href=https://www.phinsnews.com/miami-dolphins-news-original-artwork/ class=dropdown-item>Original Artwork</a></li> <li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-3526 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3526 nav-item"><a title=Video href=https://www.phinsnews.com/miami-dolphins-news-video/ class=dropdown-item>Video</a></li></ul> </li> <li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-1514 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1514 nav-item"><a title="Mission Statement" href=https://www.phinsnews.com/miami-dolphins-news-about-us/ class=nav-link>Mission Statement</a></li> <li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-9346 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9346 nav-item"><a title="Latest NFL Odds" href=https://www.acesportsbook.com/guide/lines-and-odds/nfl/ class=nav-link>Latest NFL Odds</a></li> <li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-2448 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2448 nav-item"><a title="Contact Us" href=https://www.phinsnews.com/miami-dolphins-news-contact-us/ class=nav-link>Contact Us</a></li></ul><form class="form-inline my-2 my-md-0"> <input class=form-control type=text placeholder=Search></form></div></nav><div id=primary class="container-fluid mt-3 py-5 bg-white"><div class=row><div id=content role=main class=col-md-9><div class="breadcrumbs p-0 col-md-12 mb-3"><div id=crumbs class="breadcrumb mb-0"><div itemscope itemtype=http://data-vocabulary.org/Breadcrumb><i class="fa fa-home mr-3" aria-hidden=true></i><a class=iconhome href=https://www.phinsnews.com itemprop=url><span itemprop=title>PhinsNews</span></a></div>&nbsp;&raquo;&nbsp; <a href=https://www.phinsnews.com/miami-dolphins-news-category/miami-dolphins-news/ >Miami Dolphins News</a> &nbsp;&raquo;&nbsp;<div itemscope itemtype=http://data-vocabulary.org/Breadcrumb><span class=current itemprop=title>Will Pats &#8216;Tell the Tale&#8217; on Phins Roster?</span></div></div></div><article class=post><div class=the-content><h1 class="title text-white">Will Pats &#8216;Tell the Tale&#8217; on Phins Roster?</h1><p class=has-text-align-center><strong><span class="has-inline-color has-luminous-vivid-orange-color">Phins are built to put points on,  stop the pass, and rush the passer</span></strong></p><div class=wp-block-image><figure class="alignright size-full is-resized"><a href=https://www.phinsnews.com/wp-content/uploads/2021/09/pats-vs-Dolphins.jpg><img loading=lazy src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20321%20178'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2021/09/pats-vs-Dolphins.jpg alt class="wp-image-40365 lazy" width=321 height=178 data-srcset="https://www.phinsnews.com/wp-content/uploads/2021/09/pats-vs-Dolphins.jpg 780w, https://www.phinsnews.com/wp-content/uploads/2021/09/pats-vs-Dolphins-300x167.jpg 300w, https://www.phinsnews.com/wp-content/uploads/2021/09/pats-vs-Dolphins-768x426.jpg 768w" data-sizes="(max-width: 321px) 100vw, 321px"></a></figure></div><p><strong>The Miami Dolphins set their 53 man roster a few days ago, and there were some surprises.</strong> Brian Flores and Chirs Grier have had a different approach to how they&#8217;ve built their team. So far, they have created good results. This is a big year for Tua, Flores, and the Phins franchise, so will all their roster moves come together to push them into the playoffs in 2021?<a href=https://www.phinsnews.com/miami-dolphins-news-assessing-the-2021-phins-final-roster/ > We won&#8217;t know for sure until well into the season, but the game this week against the New England Patriots will certain give a nice indication in one regard. </a></p><p>While Bill Belichick and Brian Flores are good coaches, it takes talent and the right mesh of skillsets to win. What should Phins fans make of the roster heading into Foxborough this week? And what should we expect coming out of the game?</p><h2 class="has-text-align-center">Phins chose Edwards over McKinney</h2><p><strong>When all NFL teams were required to trim their rosters down to the league required 53 man limit, the biggest surprise for the Dolphins was the release of Linebacker Benardrick McKinney.</strong> The main reason this was the biggest surprise was because the Dolphins traded Shaq Lawson to the Houston Texans for McKinney. Most <a href=https://www.aceperhead.com/aceperhead-beginners-guide.php>per head solutions</a> bet this would guarantee him a spot on the team. <strong>However, this regime once again proved no one is safe from being shown the door. </strong>With Elandon Roberts healthy, Flores felt more comfortable with Roberts than McKinney. </p><p>That was a big shock for me. But, if Miami can stop the run and Roberts makes his couple of big stops per game, then this was a big win for the Phins! <strong>On the other hand, what if the Phins struggle against the run? You&#8217;d have to start wondering if the much larger and productive McKinney should have been kept.</strong> Given how this Pats team is built, we will know very quickly if the Phins have improved at stopping the run on defense.</p><h3 class="has-text-align-center">Flores even went with Eguavoen over McKinney</h3><p>Sam Eguavoen’s monster game against the Falcons a couple weeks ago and his familiarity with Coach Flores’ defense appear to have given him the edge over McKinney. Also the other former Texan linebacker Brennan Scarlett made the team over Mckinney as well. Most thought McKinney would have been on the team before Scarlett.</p><p>I <strong>think from a team building stand point, salary played a major part of this equation as well.</strong> Did the Jerome Baker big pay out force them into making a monetary move?</p><p>Scarlett is making $1 million, Eguavoen $850k, and Edwards $1.35 million. <strong>Their combined salaries were near equal to McKinney&#8217;s contract post restructure that would have had him making $3 million with 200k in incentives!</strong> The Patriots game will tell us if Miami made more with less or less with more.</p><p><strong>Another thing to consider is given that we have a 17 game schedule this year, quality depth over peak talent may play out as the more important factor over the long haul. </strong>So, even if we do struggle to stop the run, we&#8217;ll need to see more to make any sweeping conclusions.</p><p>Either way, the Patriots will rush the ball a ton and fans will get to see what the Phins are made of against the run. <strong>I&#8217;m hoping a win and a smothering run defense is in the cards!</strong></p><p>Will depth over peak talent play out as a win for Miami? What do the rest of the Miami Dolphins news fans think?</p><form name=s2form method=post action=https://www.phinsnews.com/miami-dolphins-news-contact-us/ ><input type=hidden name=ip value=69.171.249.1><span style="display:none !important"><label for=firstname>Leave This Blank:</label><input type=text id=firstname name=firstname><label for=lastname>Leave This Blank Too:</label><input type=text id=lastname name=lastname><label for=uri>Do Not Change This:</label><input type=text id=uri name=uri value=http:// ></span><p><label for=s2email>Your email:</label><br><input type=email name=email id=s2email value="Enter email address..." size=20 onfocus="if (this.value === 'Enter email address...') {this.value = '';}" onblur="if (this.value === '') {this.value = 'Enter email address...';}"></p><p><input type=submit name=subscribe value=Subscribe>&nbsp;<input type=submit name=unsubscribe value=Unsubscribe></p></form><p></p><h3 class='coments-title'>Comment on Facebook</h3><p class=commentcount><fb:comments-count href="http://www.phinsnews.com/miami-dolphins-news-will-pats-tell-the-tale-on-phins-roster/"></fb:comments-count> comments</p><div class=fb-comments data-href=http://www.phinsnews.com/miami-dolphins-news-will-pats-tell-the-tale-on-phins-roster/ data-numposts=20 data-width=100% data-colorscheme=light></div><div class="crp_related  "><h3>Related Posts:</h3><ul><li><a href=https://www.phinsnews.com/miami-dolphins-news-nfl-considering-reducing-the-preseason-roster/     class="crp_link post-33487"><figure><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/07/roster-150x150.jpg class="crp_thumb crp_featured lazy" alt="NFL Considering Reducing the Preseason Roster" title="NFL Considering Reducing the Preseason Roster" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/07/roster-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2020/07/roster-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2020/07/roster-75x75.jpg 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/07/roster-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2020/07/roster-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2020/07/roster-75x75.jpg 75w"></figure><span class=crp_title>NFL Considering Reducing the Preseason Roster</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-did-phins-finally-find-a-gem-the-pats-dropped/     class="crp_link post-25706"><figure><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2019/07/cropped-rowe-150x150.jpg class="crp_thumb crp_featured lazy" alt="Did Phins Finally Find A Gem the Pats Dropped?" title="Did Phins Finally Find A Gem the Pats Dropped?" data-srcset="https://www.phinsnews.com/wp-content/uploads/2019/07/cropped-rowe-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2019/07/cropped-rowe-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2019/07/cropped-rowe-75x75.jpg 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2019/07/cropped-rowe-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2019/07/cropped-rowe-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2019/07/cropped-rowe-75x75.jpg 75w"></figure><span class=crp_title>Did Phins Finally Find A Gem the Pats Dropped?</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-a-phins-win-over-pats-is-a-narrative-changer/     class="crp_link post-37518"><figure><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/12/bill-150x150.png class="crp_thumb crp_featured lazy" alt="A Phins Win Over Pats Is A Narrative Changer" title="A Phins Win Over Pats Is A Narrative Changer"></figure><span class=crp_title>A Phins Win Over Pats Is A Narrative Changer</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-phins-make-another-flurry-of-roster-moves/     class="crp_link post-33959"><figure><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/07/davis-150x150.jpg class="crp_thumb crp_featured lazy" alt="Phins Make Another Flurry of Roster Moves" title="Phins Make Another Flurry of Roster Moves" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/07/davis-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2020/07/davis-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2020/07/davis-75x75.jpg 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/07/davis-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2020/07/davis-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2020/07/davis-75x75.jpg 75w"></figure><span class=crp_title>Phins Make Another Flurry of Roster Moves</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-phins-statistical-rankings-obliterating-expectations-after-3-weeks/     class="crp_link post-18135"><figure><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2018/09/bb-150x150.jpg class="crp_thumb crp_featured lazy" alt="Phins Statistical Rankings Obliterating Expectations After 3 Weeks" title="Phins Statistical Rankings Obliterating Expectations After 3 Weeks" data-srcset="https://www.phinsnews.com/wp-content/uploads/2018/09/bb-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2018/09/bb-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2018/09/bb-75x75.jpg 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2018/09/bb-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2018/09/bb-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2018/09/bb-75x75.jpg 75w"></figure><span class=crp_title>Phins Statistical Rankings Obliterating Expectations&hellip;</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-philm-study-michael-dieter-v-s-pats/     class="crp_link post-37595"><figure><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/12/diet-150x150.png class="crp_thumb crp_featured lazy" alt="Philm Study: Michael Dieter v.s. Pats" title="Philm Study: Michael Dieter v.s. Pats"></figure><span class=crp_title>Philm Study: Michael Dieter v.s. Pats</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-did-losses-to-phins-tanny-end-pats-dynasty/     class="crp_link post-29619"><figure><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/01/pats-150x150.jpg class="crp_thumb crp_featured lazy" alt="Did losses to Phins &amp; Tanny End Pats Dynasty?" title="Did losses to Phins &amp; Tanny End Pats Dynasty?" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/01/pats-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2020/01/pats-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2020/01/pats-75x75.jpg 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/01/pats-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2020/01/pats-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2020/01/pats-75x75.jpg 75w"></figure><span class=crp_title>Did losses to Phins & Tanny End Pats Dynasty?</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-phins-pass-rush-must-get-to-darnold/     class="crp_link post-17938"><figure><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2018/09/download-2-150x150.jpg class="crp_thumb crp_featured lazy" alt="Phins Pass Rush Must Get To Darnold" title="Phins Pass Rush Must Get To Darnold" data-srcset="https://www.phinsnews.com/wp-content/uploads/2018/09/download-2-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2018/09/download-2-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2018/09/download-2-75x75.jpg 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2018/09/download-2-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2018/09/download-2-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2018/09/download-2-75x75.jpg 75w"></figure><span class=crp_title>Phins Pass Rush Must Get To Darnold</span></a></li></ul><div class=crp_clear></div></div></div></article><div id=comments><div id=respond class=comment-respond><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel=nofollow id=cancel-comment-reply-link href=/miami-dolphins-news-will-pats-tell-the-tale-on-phins-roster/#respond style=display:none;>Cancel reply</a></small></h3><form action=https://www.phinsnews.com/wp-comments-post.php method=post id=commentform class=comment-form><p class=comment-notes><span id=email-notes>Your email address will not be published.</span> Required fields are marked <span class=required>*</span></p><p class=comment-form-comment><label for=comment>Comment</label><textarea id=comment name=comment cols=45 rows=8 maxlength=65525 required=required></textarea></p><p class=comment-form-author><label for=author>Name <span class=required>*</span></label> <input id=author name=author type=text value size=30 maxlength=245 required=required></p><p class=comment-form-email><label for=email>Email <span class=required>*</span></label> <input id=email name=email type=text value size=30 maxlength=100 aria-describedby=email-notes required=required></p><p class=comment-form-url><label for=url>Website</label> <input id=url name=url type=text value size=30 maxlength=200></p><p class=form-submit><input name=submit type=submit id=submit class=submit value="Post Comment"> <input type=hidden name=comment_post_ID value=40368 id=comment_post_ID> <input type=hidden name=comment_parent id=comment_parent value=0></p></form></div></div></div><div class="sidebar col-md-3"><div class=author-meta><p>Written by <b>Jimmy Bourbon</b></p></div><div class="date-meta my-3 border-top border-bottom border-secondary py-3"> 11 September, 2021</div><div class="widget my-3"><h5 class="side-title bg-dark p-3">Greatest Team in NFL History</h5><div class=textwidget><iframe src="https://www.youtube.com/embed/EBB5RGhRCz8?rel=0&amp;showinfo=0" width=100% frameborder=0 allowfullscreen=allowfullscreen></iframe></div></div><div class="widget my-3"><div class=textwidget><div class="side-box mb-3"> <a href="https://www.aceperhead.com/signup.php?CMPID=UGhpbnM%3D" target=_blank rel="nofollow noopener"><br> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/09/ace-banner-w300xh250.gif alt="aceperhead 6 weeks free" class="w-100 lazy"><br> </a></div></div></div><div class="widget my-3"><div class=textwidget><p><a class="btn btn-primary w-100 d-block" href=https://www.aceperhead.com/signup.php>Pay Per Head Bookie Service</a></p></div></div><div class="widget my-3"><div class=textwidget><p><iframe loading=lazy src=https://www.youtube.com/embed/KMsskKpV7Ss width=100% frameborder=0 allowfullscreen=allowfullscreen></iframe></p></div></div></div></div></div></div><div class="ads my-5 w-100 text-center desktop"> <a href="https://www.aceperhead.com/signup.php?CMPID=UGhpbnM%3D" target=_blank rel=nofollow> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/09/ace-banner-w728xh90.gif class="w-100 m-auto lazy" alt="aceperhead 6 weeks free" style="max-width: 728px;"> </a></div></div><div class="footer bg-dark mt-2"><div class="container p-3"><div class=recent-post></div><div class="copy text-center text-white"> All Rights Reserved © 2021 <a href=https://www.phinsnews.com/sitemap/ >Miami Dolphins News</a> written for and by Phins fans! </a></div></div></div><div id=fb-root></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=1540991332841094&version=v2.0";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id=jquery-ui-core-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.12.1' id=jquery-ui-mouse-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.12.1' id=jquery-ui-resizable-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.12.1' id=jquery-ui-draggable-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/controlgroup.min.js?ver=1.12.1' id=jquery-ui-controlgroup-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/checkboxradio.min.js?ver=1.12.1' id=jquery-ui-checkboxradio-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/button.min.js?ver=1.12.1' id=jquery-ui-button-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.12.1' id=jquery-ui-dialog-js></script> <script id=s2-ajax-js-extra>var s2AjaxScriptStrings={"ajaxurl":"https:\/\/www.phinsnews.com\/wp-admin\/admin-ajax.php","title":"Subscribe to this blog","nonce":"d35af4496d"};</script> <script src='https://www.phinsnews.com/wp-content/plugins/subscribe2/include/s2-ajax.min.js?ver=1.3' id=s2-ajax-js></script> <script src='https://www.phinsnews.com/wp-content/plugins/yith-infinite-scrolling/assets/js/yith.infinitescroll.min.js?ver=1.5.2' id=yith-infinitescroll-js></script> <script id=yith-infs-js-extra>var yith_infs={"navSelector":"nav.navigation","nextSelector":"nav.navigation a.next","itemSelector":"article.post","contentSelector":"#main","loader":"https:\/\/www.phinsnews.com\/wp-content\/plugins\/yith-infinite-scrolling\/assets\/images\/loader.gif","shop":""};</script> <script src='https://www.phinsnews.com/wp-content/plugins/yith-infinite-scrolling/assets/js/yith-infs.min.js?ver=1.5.2' id=yith-infs-js></script> <script src='https://www.phinsnews.com/wp-content/themes/phins/js/theme.min.js?ver=1' id=bootstrap-js></script> <script src='https://www.googletagmanager.com/gtag/js?id=UA-48791348-1&#038;ver=1' id=analytics-js></script>  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-48791348-1"></script> <script>window.w3tc_lazyload=1,window.lazyLoadOptions={elements_selector:".lazy",callback_loaded:function(t){var e;try{e=new CustomEvent("w3tc_lazyload_loaded",{detail:{e:t}})}catch(a){(e=document.createEvent("CustomEvent")).initCustomEvent("w3tc_lazyload_loaded",!1,!1,{e:t})}window.dispatchEvent(e)}}</script><script async src=https://www.phinsnews.com/wp-content/plugins/w3-total-cache/pub/js/lazyload.min.js></script></body></html>