<!DOCTYPE html><html lang=en-US xmlns:og=http://opengraphprotocol.org/schema/ xmlns:fb=http://www.facebook.com/2008/fbml prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# article: http://ogp.me/ns/article#"><head><style>img.lazy{min-height:1px}</style><link rel=preload href=https://www.phinsnews.com/wp-content/plugins/w3-total-cache/pub/js/lazyload.min.js as=script><meta charset="UTF-8"><meta name="viewport" content="width=device-width"><meta name="description" content="Phins News"><meta name="keywords" content="Phins News"><meta name="theme-color" content="#00838d"><meta name="apple-mobile-web-app-status-bar-style" content="#00838d"><meta name="msapplication-navbutton-color" content="#00838d"><title>COVID Draft Rules give Phins huge edge by coaching the Senior Bowl.</title><link rel=profile href=http://gmpg.org/xfn/11><link rel=pingback href=https://www.phinsnews.com/xmlrpc.php><link href="https://fonts.googleapis.com/css2?family=Montserrat:ital,wght@0,100;0,200;0,300;0,400;0,500;0,600;0,700;0,800;0,900;1,100;1,200;1,300;1,400;1,500;1,600;1,700;1,800;1,900&display=swap" rel=stylesheet> <!--[if lt IE 9]> <script src=https://www.phinsnews.com/wp-content/themes/phins/js/html5.js></script> <![endif]--><link rel=canonical href=http://www.phinsnews.com/miami-dolphins-news-covid-draft-rules-give-phins-huge-edge/ ><link rel=alternate href=https://www.phinsnews.com/en-us hreflang=en-us><meta name="description" content="COVID Draft Rules are changing this year&#039;s format on how NFL coaches and the rookies interact. So the Phins have huge edge with coaching the Senior Bowl."><meta property="og:type" content="article"><meta property="article:published_time" content="2021-01-27"><meta property="article:modified_time" content="2021-01-27"><meta property="article:author" content="https://www.phinsnews.com/miami-dolphins-news-author/swriter3/"><meta property="article:section" content="Miami Dolphins News"><meta property="article:tag" content="Miami Dolphins 2021 Season"><meta property="article:tag" content="slider"><meta property="og:title" content="COVID Draft Rules give Phins huge edge by coaching the Senior Bowl."><meta property="og:description" content="COVID Draft Rules are changing this year&#039;s format on how NFL coaches and the rookies interact. So the Phins have huge edge with coaching the Senior Bowl."><meta property="og:url" content="https://www.phinsnews.com/miami-dolphins-news-covid-draft-rules-give-phins-huge-edge/"><meta property="og:image" content="https://www.phinsnews.com/wp-content/uploads/2021/01/flosb.png"><meta property="og:site_name" content="Phins News"><meta name="twitter:card" content="summary"><meta name="twitter:title" content="COVID Draft Rules give Phins huge edge by coaching the Senior Bowl."><meta name="twitter:description" content="COVID Draft Rules are changing this year&#039;s format on how NFL coaches and the rookies interact. So the Phins have huge edge with coaching the Senior Bowl."><meta name="twitter:image" content="https://www.phinsnews.com/wp-content/uploads/2021/01/flosb.png"><meta name="google-site-verification" content="9nKubAwUaU4mUqCgJt4Ja7BdkUYNt7t114Zu34vnCLE"><link rel=dns-prefetch href=//www.googletagmanager.com><link rel=dns-prefetch href=//ajax.googleapis.com><link rel=dns-prefetch href=//s.w.org><link rel=alternate type=application/rss+xml title="Phins News &raquo; Feed" href=https://www.phinsnews.com/feed/ ><link rel=alternate type=application/rss+xml title="Phins News &raquo; Comments Feed" href=https://www.phinsnews.com/comments/feed/ ><link rel=alternate type=application/rss+xml title="Phins News &raquo; COVID Draft Rules Give Phins Huge Edge Comments Feed" href=https://www.phinsnews.com/miami-dolphins-news-covid-draft-rules-give-phins-huge-edge/feed/ > <script>window._wpemojiSettings={"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.phinsnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style>img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0
.07em !important;vertical-align:-0.1em !important;background:none !important;padding:0
!important}</style><link rel=stylesheet id=wp-block-library-css  href='https://www.phinsnews.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6' type=text/css media=all><link rel=stylesheet id=crp-style-rounded-thumbs-css  href='https://www.phinsnews.com/wp-content/plugins/contextual-related-posts/css/rounded-thumbs.min.css?ver=1.0' type=text/css media=all><style id=crp-style-rounded-thumbs-inline-css>.crp_related
a{width:150px;height:150px;text-decoration:none}.crp_related
img{max-width:150px;margin:auto}.crp_related
.crp_title{width:100%}</style><link rel=stylesheet id=st_css-css  href='https://www.phinsnews.com/wp-content/plugins/seoupro/modules/semtags/css/semantic_tags.css?ver=5.6' type=text/css media=all><link rel=stylesheet id=jquery-ui-style-css  href='https://ajax.googleapis.com/ajax/libs/jqueryui/1.11.4/themes/ui-darkness/jquery-ui.css?ver=1.11.4' type=text/css media=all><link rel=stylesheet id=yith-infs-style-css  href='https://www.phinsnews.com/wp-content/plugins/yith-infinite-scrolling/assets/css/frontend.css?ver=1.4.0' type=text/css media=all><link rel=stylesheet id=style.css-css  href='https://www.phinsnews.com/wp-content/themes/phins/style.css?ver=5.6' type=text/css media=all> <script src='https://www.phinsnews.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id=jquery-core-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id=jquery-migrate-js></script> <script src='https://www.phinsnews.com/wp-content/plugins/seoupro/modules/schema/assets/js/knockout-min.js?ver=5.6' id=knockout-js></script> <link rel=https://api.w.org/ href=https://www.phinsnews.com/wp-json/ ><link rel=alternate type=application/json href=https://www.phinsnews.com/wp-json/wp/v2/posts/38025><link rel=EditURI type=application/rsd+xml title=RSD href=https://www.phinsnews.com/xmlrpc.php?rsd><link rel=wlwmanifest type=application/wlwmanifest+xml href=https://www.phinsnews.com/wp-includes/wlwmanifest.xml><meta name="generator" content="WordPress 5.6"><link rel=shortlink href='https://www.phinsnews.com/?p=38025'><link rel=alternate type=application/json+oembed href="https://www.phinsnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.phinsnews.com%2Fmiami-dolphins-news-covid-draft-rules-give-phins-huge-edge%2F"><link rel=alternate type=text/xml+oembed href="https://www.phinsnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.phinsnews.com%2Fmiami-dolphins-news-covid-draft-rules-give-phins-huge-edge%2F&#038;format=xml"><style>0</style><meta property="fb:app_id" content="1540991332841094"><meta property="fb:admins" content=""><meta property="og:locale" content="en_US"><meta property="og:locale:alternate" content="en_US"><link rel=amphtml href=https://www.phinsnews.com/miami-dolphins-news-covid-draft-rules-give-phins-huge-edge/amp/ ><link rel=icon href=https://www.phinsnews.com/wp-content/uploads/2020/09/logo.png sizes=32x32><link rel=icon href=https://www.phinsnews.com/wp-content/uploads/2020/09/logo.png sizes=192x192><link rel=apple-touch-icon href=https://www.phinsnews.com/wp-content/uploads/2020/09/logo.png><meta name="msapplication-TileImage" content="https://www.phinsnews.com/wp-content/uploads/2020/09/logo.png">  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-48791348-1"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag('js',new Date());gtag('config','UA-48791348-1');</script> <meta name="google-site-verification" content="9nKubAwUaU4mUqCgJt4Ja7BdkUYNt7t114Zu34vnCLE"></head><body class="post-template-default single single-post postid-38025 single-format-standard wp-custom-logo"><div id=phins class=container><div class="head row py-3"><div class="col-md-6 logo"><div class="d-flex align-items-center"> <a href=https://www.phinsnews.com/ class=custom-logo-link rel=home><img width=128 height=131 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20128%20131'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/09/logo.png class="custom-logo lazy" alt="Phins News"></a>		<a class="site-title ml-2" href=https://www.phinsnews.com/ ><h1>Miami Dolphins News written for and by Phins fans!</h1> </a></div></div><div class="col-md-6 d-flex align-items-center desktop"><div class=ads> <a href="https://www.aceperhead.com/signup.php?CMPID=UGhpbnM%3D" target=_blank rel=nofollow> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/09/ace-banner-w728xh90.gif class="w-100 lazy" alt="aceperhead 6 weeks free"> </a></div></div></div><nav class="navbar navbar-expand-lg navbar-dark bg-dark border-nav"> <button class=navbar-toggler type=button data-toggle=collapse data-target=#mainNav aria-controls=mainNav aria-expanded=false aria-label="Toggle navigation"> <span class=navbar-toggler-icon></span> </button><div class="collapse navbar-collapse text-uppercase" id=mainNav><ul id=menu-menu-1 class="navbar-nav mr-auto"><li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-9317 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9317 nav-item"><a title=Home href=https://www.phinsnews.com/ class=nav-link>Home</a></li><li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-3523 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children dropdown menu-item-3523 nav-item"><a title=MultiMedia href=# data-toggle=dropdown aria-haspopup=true aria-expanded=false class="dropdown-toggle nav-link" id=menu-item-dropdown-3523>MultiMedia</a><ul class=dropdown-menu aria-labelledby=menu-item-dropdown-3523 role=menu><li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-3525 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3525 nav-item"><a title="Classic Pics" href=https://www.phinsnews.com/miami-dolphins-news-classic-pics/ class=dropdown-item>Classic Pics</a></li><li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-3524 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3524 nav-item"><a title="Original Artwork" href=https://www.phinsnews.com/miami-dolphins-news-original-artwork/ class=dropdown-item>Original Artwork</a></li><li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-3526 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3526 nav-item"><a title=Video href=https://www.phinsnews.com/miami-dolphins-news-video/ class=dropdown-item>Video</a></li></ul></li><li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-1514 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1514 nav-item"><a title="Mission Statement" href=https://www.phinsnews.com/miami-dolphins-news-about-us/ class=nav-link>Mission Statement</a></li><li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-9346 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9346 nav-item"><a title="Latest NFL Odds" href=https://www.acesportsbook.com/guide/lines-and-odds/nfl/ class=nav-link>Latest NFL Odds</a></li><li itemscope=itemscope itemtype=https://www.schema.org/SiteNavigationElement id=menu-item-2448 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2448 nav-item"><a title="Contact Us" href=https://www.phinsnews.com/miami-dolphins-news-contact-us/ class=nav-link>Contact Us</a></li></ul><form class="form-inline my-2 my-md-0"> <input class=form-control type=text placeholder=Search></form></div></nav><div id=primary class="container-fluid mt-3 py-5 bg-white"><div class=row><div id=content role=main class=col-md-9><div class="breadcrumbs p-0 col-md-12 mb-3"><div id=crumbs class="breadcrumb mb-0"><div itemscope itemtype=http://data-vocabulary.org/Breadcrumb><i class="fa fa-home mr-3" aria-hidden=true></i><a class=iconhome href=https://www.phinsnews.com itemprop=url><span itemprop=title>PhinsNews</span></a></div>&nbsp;&raquo;&nbsp; <a href=https://www.phinsnews.com/miami-dolphins-news-category/miami-dolphins-news/ >Miami Dolphins News</a> &nbsp;&raquo;&nbsp;<div itemscope itemtype=http://data-vocabulary.org/Breadcrumb><span class=current itemprop=title>COVID Draft Rules Give Phins Huge Edge</span></div></div></div><article class=post><div class=the-content><h1 class="title text-white">COVID Draft Rules Give Phins Huge Edge</h1><h2 class="has-text-align-center"><span class="has-inline-color has-luminous-vivid-orange-color">Phins get a major leg up by coaching Senior Bowl</span></h2><div class=wp-block-image><figure class="alignright size-large"><a href=https://www.phinsnews.com/wp-content/uploads/2021/01/flosb.png><img loading=lazy width=210 height=194 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20210%20194'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2021/01/flosb.png alt class="wp-image-38028 lazy"></a></figure></div><p><strong>As all Phins fans know,</strong> <strong>this Saturday the Miami Dolphins staff will coach in the Reese’s Senior Bowl.&nbsp;</strong>Between the practice and the game, the Phins have a near week to get an up-close and personal look at some of the top seniors in the nation entering the 2021 Draft. <a href=https://www.phinsnews.com/miami-dolphins-news-coaching-in-senior-bowl-is-a-phins-win/ >While this opportunity is always an advantage, this year it will be even a greater advantage due to new COVID rules that will limit teams and rookie interaction. </a></p><h3 class="has-text-align-center">Flores plays a key role in the Phins draft</h3><p>Last year, Brian Flores had a unique opportunity to have a private workout with draft prospects from Auburn. <strong>The Dolphins ended up selecting Noah Igbinoghene in the 1st Round, who was one of those Auburn players.</strong>&nbsp;Now, many said Igbinoghene was a reach&#8230; and he definitely didn’t show dividends this season. But, it&#8217;s clear Flores saw something in Igbinoghene and used his influence to make his selection happen.</p><p>Now, I would have preferred one of the top-rated running backs, but Igbinoghene is still a young and raw player so he shouldn’t be labeled as a bust this early. <strong>The bottom line is Flores is spending time with two of my dream picks in WR Smith and RB Harris from Alabama.</strong> Hopefully, Flores seeing them up close for an extended period of time will lead the Phins to draft both of them.</p><p><strong>Considering how limited the interactions will be now because of COVID, this close up look could be the deciding factor over another player.</strong></p><p>The new rules for interviews are:</p><p><a href=https://www.oregonlive.com/coronavirus/2021/01/nfl-changes-format-of-2021-scouting-combine-due-to-covid-19.html>&#8220;Other major changes include no in-person workouts. All workouts will take place during individual pro days on college campuses. The league will be working on the structure of providing video of individual workouts to all teams. Teams can conduct 15-minute interviews with players virtually only. &#8220;</a></p><h3 class="has-text-align-center">Okay, maybe we won&#8217;t get both of them</h3><p>While I play the Dolphins GM in these articles, I don’t actually get the luxury of making the decisions on Draft Day&#8230;</p><p> &#8230; So, I doubt the Dolphins fall in love with both of my two choices. But, I&#8217;ve got to believe they&#8217;ll walk away with at least one of them!</p><h3 class="has-text-align-center">Flores must have his eye on some defenders</h3><p><strong>Since coach Flores is a defensive-minded coach, I wouldn’t be surprised if one or two seniors end up getting selected by the Phins at some point during the draft as well.</strong> </p><p>Remember, we have 4 picks in the Top 50!</p><p>With what we saw last year with Igbinoghene, it’s hard to imagine this changing since Flores will get even more time with these Senior players. The question is who will they target? North Carolina ILB Chazz Surratt could be one of them. Or maybe Ohio State OLB <strong>Baron Browning</strong>?</p><h3>If you&#8217;ve never paid attention to a Senior Bowl&#8230; this one you should</h3><p><strong>Bet with the <a href=https://www.aceperhead.com/sportsbook.php>best bookmaker software providers</a> that this Senior Bowl will be a big factor come this draft.</strong> The only quesation is who will they pull the trigger on come Draft Day?</p><p>What are the rest of the Miami Dolphins News fans&#8217; thoughts about the value of this Senior Bowl</p><form name=s2form method=post action=https://www.phinsnews.com/miami-dolphins-news-contact-us/ ><input type=hidden name=ip value=172.58.203.179><span style="display:none !important"><label for=firstname>Leave This Blank:</label><input type=text id=firstname name=firstname><label for=lastname>Leave This Blank Too:</label><input type=text id=lastname name=lastname><label for=uri>Do Not Change This:</label><input type=text id=uri name=uri value=http:// ></span><p><label for=s2email>Your email:</label><br><input type=email name=email id=s2email value="Enter email address..." size=20 onfocus="if (this.value === 'Enter email address...') {this.value = '';}" onblur="if (this.value === '') {this.value = 'Enter email address...';}"></p><p><input type=submit name=subscribe value=Subscribe>&nbsp;<input type=submit name=unsubscribe value=Unsubscribe></p></form><p></p><h3 class='coments-title'>Comment on Facebook</h3><p class=commentcount><fb:comments-count href="http://www.phinsnews.com/miami-dolphins-news-covid-draft-rules-give-phins-huge-edge/"></fb:comments-count> comments</p><div class=fb-comments data-href=http://www.phinsnews.com/miami-dolphins-news-covid-draft-rules-give-phins-huge-edge/ data-numposts=20 data-width=100% data-colorscheme=light></div><div class="crp_related  "><h3>Related Posts:</h3><ul><li><a href=https://www.phinsnews.com/miami-dolphins-news-phins-give-reshad-jones-the-inglorious-boot/     class="crp_link post-30863"><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/03/jones-150x150.png class="crp_thumb crp_featured lazy" alt="Phins Give Reshad Jones the &#039;Inglorious Boot&#039;" title="Phins Give Reshad Jones the &#039;Inglorious Boot&#039;" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/03/jones-150x150.png 150w, https://www.phinsnews.com/wp-content/uploads/2020/03/jones-90x90.png 90w, https://www.phinsnews.com/wp-content/uploads/2020/03/jones-75x75.png 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/03/jones-150x150.png 150w, https://www.phinsnews.com/wp-content/uploads/2020/03/jones-90x90.png 90w, https://www.phinsnews.com/wp-content/uploads/2020/03/jones-75x75.png 75w"><span class=crp_title>Phins Give Reshad Jones the 'Inglorious Boot'</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-grier-can-draft-phins-back-into-relevancy/     class="crp_link post-31433"><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/04/draft-150x150.jpg class="crp_thumb crp_featured lazy" alt="Grier Can Draft Phins Back Into Relevancy!" title="Grier Can Draft Phins Back Into Relevancy!" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/04/draft-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2020/04/draft-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2020/04/draft-75x75.jpg 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/04/draft-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2020/04/draft-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2020/04/draft-75x75.jpg 75w"><span class=crp_title>Grier Can Draft Phins Back Into Relevancy!</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-dolphins-2017-draft-class-2018-pay-off-time/     class="crp_link post-14702"><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2018/03/48367_harris-1-150x150.jpg class="crp_thumb crp_featured lazy" alt="Dolphins 2017 Draft Class: 2018 Pay-Off Time?" title="Dolphins 2017 Draft Class: 2018 Pay-Off Time?"><span class=crp_title>Dolphins 2017 Draft Class: 2018 Pay-Off Time?</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-will-covid-19-hit-the-nfl-salary-cap/     class="crp_link post-32713"><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/06/1-150x150.jpg class="crp_thumb crp_featured lazy" alt="Will Covid-19 Hit the NFL Salary Cap?" title="Will Covid-19 Hit the NFL Salary Cap?" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/06/1-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2020/06/1-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2020/06/1-75x75.jpg 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/06/1-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2020/06/1-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2020/06/1-75x75.jpg 75w"><span class=crp_title>Will Covid-19 Hit the NFL Salary Cap?</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-possible-safety-option-in-phins-draft/     class="crp_link post-31088"><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/03/jr-150x150.jpg class="crp_thumb crp_featured lazy" alt="Possible Safety Option in Phins Draft" title="Possible Safety Option in Phins Draft" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/03/jr-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2020/03/jr-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2020/03/jr-75x75.jpg 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2020/03/jr-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2020/03/jr-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2020/03/jr-75x75.jpg 75w"><span class=crp_title>Possible Safety Option in Phins Draft</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-dolphins-tepid-free-agency-demands-hot-draft/     class="crp_link post-22488"><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2019/03/nfld-150x150.jpg class="crp_thumb crp_featured lazy" alt="Dolphins &#039;Tepid&#039; Free Agency Demands Hot Draft" title="Dolphins &#039;Tepid&#039; Free Agency Demands Hot Draft" data-srcset="https://www.phinsnews.com/wp-content/uploads/2019/03/nfld-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2019/03/nfld-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2019/03/nfld-75x75.jpg 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2019/03/nfld-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2019/03/nfld-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2019/03/nfld-75x75.jpg 75w"><span class=crp_title>Dolphins 'Tepid' Free Agency Demands Hot Draft</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-phins-draft-examing-dts-wilkins-lawrence-oliver/     class="crp_link post-22801"><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2019/03/13-150x150.jpg class="crp_thumb crp_featured lazy" alt="Phins Draft: Examing DTs Wilkins, Lawrence, &amp; Oliver" title="Phins Draft: Examing DTs Wilkins, Lawrence, &amp; Oliver" data-srcset="https://www.phinsnews.com/wp-content/uploads/2019/03/13-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2019/03/13-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2019/03/13-75x75.jpg 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2019/03/13-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2019/03/13-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2019/03/13-75x75.jpg 75w"><span class=crp_title>Phins Draft: Examing DTs Wilkins, Lawrence, & Oliver</span></a></li><li><a href=https://www.phinsnews.com/miami-dolphins-news-broncos-flacco-trade-1st-salvo-in-2019-draft/     class="crp_link post-21051"><img loading=lazy  width=150 height=150  src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2019/02/draft-150x150.jpg class="crp_thumb crp_featured lazy" alt="Broncos Flacco Trade 1st Salvo In 2019 Draft" title="Broncos Flacco Trade 1st Salvo In 2019 Draft" data-srcset="https://www.phinsnews.com/wp-content/uploads/2019/02/draft-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2019/02/draft-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2019/02/draft-75x75.jpg 75w" data-sizes="(max-width: 150px) 100vw, 150px" data-srcset="https://www.phinsnews.com/wp-content/uploads/2019/02/draft-150x150.jpg 150w, https://www.phinsnews.com/wp-content/uploads/2019/02/draft-90x90.jpg 90w, https://www.phinsnews.com/wp-content/uploads/2019/02/draft-75x75.jpg 75w"><span class=crp_title>Broncos Flacco Trade 1st Salvo In 2019 Draft</span></a></li></ul><div class=crp_clear></div></div></div></article><div id=comments><div id=respond class=comment-respond><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel=nofollow id=cancel-comment-reply-link href=/miami-dolphins-news-covid-draft-rules-give-phins-huge-edge/#respond style=display:none;>Cancel reply</a></small></h3><form action=https://www.phinsnews.com/wp-comments-post.php method=post id=commentform class=comment-form><p class=comment-notes><span id=email-notes>Your email address will not be published.</span> Required fields are marked <span class=required>*</span></p><p class=comment-form-comment><label for=comment>Comment</label><textarea id=comment name=comment cols=45 rows=8 maxlength=65525 required=required></textarea></p><p class=comment-form-author><label for=author>Name <span class=required>*</span></label> <input id=author name=author type=text value size=30 maxlength=245 required=required></p><p class=comment-form-email><label for=email>Email <span class=required>*</span></label> <input id=email name=email type=text value size=30 maxlength=100 aria-describedby=email-notes required=required></p><p class=comment-form-url><label for=url>Website</label> <input id=url name=url type=text value size=30 maxlength=200></p><p class=form-submit><input name=submit type=submit id=submit class=submit value="Post Comment"> <input type=hidden name=comment_post_ID value=38025 id=comment_post_ID> <input type=hidden name=comment_parent id=comment_parent value=0></p></form></div></div></div><div class="sidebar col-md-3"><div class=author-meta><p>Written by <b>Jimmy Bourbon</b></p></div><div class="date-meta my-3 border-top border-bottom border-secondary py-3"> 27 January, 2021</div><div class="widget my-3"><h5 class="side-title bg-dark p-3">Greatest Team in NFL History</h5><div class=textwidget><iframe src="https://www.youtube.com/embed/EBB5RGhRCz8?rel=0&amp;showinfo=0" width=100% frameborder=0 allowfullscreen=allowfullscreen></iframe></div></div><div class="widget my-3"><div class=textwidget><div class="side-box mb-3"> <a href="https://www.aceperhead.com/signup.php?CMPID=UGhpbnM%3D" target=_blank rel="nofollow noopener"><br> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/09/ace-banner-w300xh250.gif alt="aceperhead 6 weeks free" class="w-100 lazy"><br> </a></div></div></div><div class="widget my-3"><div class=textwidget><p><a class="btn btn-primary w-100 d-block" href=https://www.aceperhead.com/signup.php>Pay Per Head Bookie Service</a></p></div></div><div class="widget my-3"><div class=textwidget><p><iframe src=https://www.youtube.com/embed/KMsskKpV7Ss width=100% frameborder=0 allowfullscreen=allowfullscreen></iframe></p></div></div></div></div></div></div><div class="ads my-5 w-100 text-center desktop"> <a href="https://www.aceperhead.com/signup.php?CMPID=UGhpbnM%3D" target=_blank rel=nofollow> <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201%201'%3E%3C/svg%3E" data-src=https://www.phinsnews.com/wp-content/uploads/2020/09/ace-banner-w728xh90.gif class="w-100 m-auto lazy" alt="aceperhead 6 weeks free" style="max-width: 728px;"> </a></div></div><div class="footer bg-dark mt-2"><div class="container p-3"><div class=recent-post></div><div class="copy text-center text-white"> All Rights Reserved © 2021 <a href=https://www.phinsnews.com/sitemap/ >Miami Dolphins News</a> written for and by Phins fans! </a></div></div></div><div id=fb-root></div> <script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=1540991332841094&version=v2.0";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id=jquery-ui-core-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.12.1' id=jquery-ui-mouse-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.12.1' id=jquery-ui-resizable-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.12.1' id=jquery-ui-draggable-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/controlgroup.min.js?ver=1.12.1' id=jquery-ui-controlgroup-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/checkboxradio.min.js?ver=1.12.1' id=jquery-ui-checkboxradio-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/button.min.js?ver=1.12.1' id=jquery-ui-button-js></script> <script src='https://www.phinsnews.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.12.1' id=jquery-ui-dialog-js></script> <script id=s2-ajax-js-extra>var s2AjaxScriptStrings={"ajaxurl":"https:\/\/www.phinsnews.com\/wp-admin\/admin-ajax.php","title":"Subscribe to this blog","nonce":"61e2f67b6d"};</script> <script src='https://www.phinsnews.com/wp-content/plugins/subscribe2/include/s2-ajax.min.js?ver=1.3' id=s2-ajax-js></script> <script src='https://www.phinsnews.com/wp-content/plugins/yith-infinite-scrolling/assets/js/yith.infinitescroll.min.js?ver=1.4.0' id=yith-infinitescroll-js></script> <script id=yith-infs-js-extra>var yith_infs={"navSelector":"nav.navigation","nextSelector":"nav.navigation a.next","itemSelector":"article.post","contentSelector":"#main","loader":"https:\/\/www.phinsnews.com\/wp-content\/plugins\/yith-infinite-scrolling\/assets\/images\/loader.gif","shop":""};</script> <script src='https://www.phinsnews.com/wp-content/plugins/yith-infinite-scrolling/assets/js/yith-infs.min.js?ver=1.4.0' id=yith-infs-js></script> <script src='https://www.phinsnews.com/wp-content/themes/phins/js/theme.min.js?ver=1' id=bootstrap-js></script> <script src='https://www.googletagmanager.com/gtag/js?id=UA-48791348-1&#038;ver=1' id=analytics-js></script>  <script async src="https://www.googletagmanager.com/gtag/js?id=UA-48791348-1"></script> <script>window.w3tc_lazyload=1,window.lazyLoadOptions={elements_selector:".lazy",callback_loaded:function(t){var e;try{e=new CustomEvent("w3tc_lazyload_loaded",{detail:{e:t}})}catch(a){(e=document.createEvent("CustomEvent")).initCustomEvent("w3tc_lazyload_loaded",!1,!1,{e:t})}window.dispatchEvent(e)}}</script><script async src=https://www.phinsnews.com/wp-content/plugins/w3-total-cache/pub/js/lazyload.min.js></script></body></html>